Upgrade from 3.8.x to 4.0.0

1. The grid.postext.js module is no more supported.

The module is moved to plugins directory. In case you want to use it you should include it manually.
If you want to upgrade you code should be changed as follow:

Old MethodReplacement
jQuery(”#grid_id”).jqGrid('getPostData') jQuery(”#grid_id”).jqGrid('getGridParam','postData')
jQuery(”#grid_id”).jqGrid('setPostData', newdata) jQuery(”#grid_id”).jqGrid('setGridParam',{postData: null});
jQuery(”#grid_id”).jqGrid('setGridParam',{postData:newdata})
jQuery(”#grid_id”).jqGrid('appendPostData', newdata) jQuery(”#grid_id”).jqGrid('setGridParam',{postData:newdata})
jQuery(”#grid_id”).jqGrid('setPostDataItem', 'key', 'val') jQuery(”#grid_id”).jqGrid('setGridParam',{postData:{'key':'val'} })
jQuery(”#grid_id”).jqGrid('getPostDataItem', 'key' ) jQuery(”#grid_id”).jqGrid('getGridParam', 'postData' )['key']
jQuery(”#grid_id”).jqGrid('removePostDataItem', 'key' ) delete jQuery(”#grid_id”).jqGrid('getGridParam' ,'postData' )[key]
jQuery(”#grid_id”).jqGrid('getUserData' ) jQuery(”#grid_id”).jqGrid('getGridParam', 'userData' )
jQuery(”#grid_id”).jqGrid('getUserDataItem','key' ) jQuery(”#grid_id”).jqGrid('getGridParam', 'userData' )[key]

2. The grid.setcolumns.js module is no more supported.

The module is moved to plugins directory. In case you want to use it you should include it manually.

The module contain only one method : setColumns . The method can be replaced with the columnChooser method.

3. The following methods are no more supported:

updateGridRows
filterGrid
searchGrid (with searchFilter plugin )

The methods are included in new file called grid.addons.js. The module is plugins directory. In case you want to use it you should include it manually.

4. The searchFilter plugin is no more used in searching modules

The module (jquery.searchFilter.js) and CSS file (searchFilter.css) are moved to plugins directory. In case you want to use it you should include it manually.


Personal Tools
;
;