Forum

November 2nd, 2014
A A A
Avatar

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

The forums are currently locked and only available for read only access
sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
Multiple Search - Multiple Criteria Same Field
23/09/2010
23:04
Avatar
demongolem
Member
Members
Forum Posts: 5
Member Since:
22/09/2010
sp_UserOfflineSmall Offline

Hi all,

I want to do something as conceptually simple as:

 ID less 10

 ID greater 5

 match all rules

My first thought is to try to have two separate rows and then do find.  But when I do so, the second operator, no matter which one I select (in this case it is gt), does not get returned in the filter.  Instead I get back the ID and the 5 correctly but the word "undefined" when I try to get the operator.  Any ideas why I can not pick up this second operator. BTW, I do capture the first operator, the lt, in this scenario. 

So then, I want to know is this the correct way to perform this search with jqGrid or is there something like a between operation or something like that sort to handle this case.

23/09/2010
23:35
Avatar
demongolem
Member
Members
Forum Posts: 5
Member Since:
22/09/2010
sp_UserOfflineSmall Offline

I see a similar problem at /blog/?page_id=393/help/multisearch-return-datas-as-undefined-when-twice-or-more/&value=operator%20undefined&type=2&include=1&search=1&ret=all.  For that case, the user was experiencing the problem with the data, whereas it is the operator for me.

When I try Firefox, EVERYTHING WORKS GREAT!  When I use IE 7, that is where the problems occur.  My end users have IE 7 so I have no choice.  Could please someone check if this is a legitimate bug.  I am using the sjg tags which uses jqGrid 3.7.2.  If it has been fixed since then please advise.

24/09/2010
10:02
Avatar
tony
Sofia, Bulgaria
Moderator
Members

Moderators
Forum Posts: 7721
Member Since:
30/10/2007
sp_UserOfflineSmall Offline

Hello,

Sorry to say this, but this is a bug in jQuery clone function in IE7

http://dev.jquery.com/ticket/4417

when it is applied into the select element. This actually we do into the code.

Seems the bug is not corrected.

Kind Regards

Tony

For professional UI suites for Java Script and PHP visit us at our commercial products site - guriddo.net - by the very same guys that created jqGrid.

Forum Timezone: Europe/Sofia

Most Users Ever Online: 376

Currently Online:
30 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

OlegK: 1255

markw65: 179

kobruleht: 144

phicarre: 132

YamilBracho: 124

Renso: 118

Member Stats:

Guest Posters: 447

Members: 11373

Moderators: 2

Admins: 1

Forum Stats:

Groups: 1

Forums: 8

Topics: 10592

Posts: 31289

Newest Members:

razia, Prankie, psky, praveen neelam, greg.valainis@pa-tech.com, swathi

Moderators: tony: 7721, Rumen[Trirand]: 81

Administrators: admin: 66

Comments are closed.
Privacy Policy   Terms and Conditions   Contact Information